Wikipedia:WikiReader/OpenOffice Tipps

aus Wikipedia, der freien Enzyklopädie
Wechseln zu: Navigation, Suche

Diese Seite gehört zum Wikipedia-Archiv.

Der Inhalt dieser Seite ist nicht mehr aktuell. Sie wird aber nicht gelöscht, damit die Geschichte der Wikipedia nicht verlorengeht. Falls es sich um eine Arbeitsunterlage handelt, ist sie womöglich durch andere Seiten ersetzt worden. Bestehende Weiterleitungen auf diese Seite sollen das Wiederauffinden ermöglichen.

Wenn du meinst, diese Seite sei weiterhin von aktueller Bedeutung, solle weiter benutzt werden und ihre Funktion sei nicht besser in bestehende Seiten integriert, dann kümmere dich um ihre Aktualisierung.

Diese Seite dient dazu, Tipps zu sammeln, die einem beim Erstellen eines WikiReaders mit OpenOffice.org nützlich sein können. Bei Problemen oder Fragen kann man einen neuen Absatz anhängen; allerdings dient diese Seite nicht für den allgemeinen Support zu OpenOffice.org, dafür gibt es eine Mailingliste (extern).

Seitennummerierung[Bearbeiten]

Erst eine Fußzeile einfügen Einfügen->Fußzeile->Standard. In diese dann Einfügen->Feldbefehl->Seitennummer (Achtung! - nicht Seitenanzahl).

Die Nummerierung beginnt standardmäßig auf der ersten Seite. Will man die Nummerierung auf der zweiten Seite beginnen lassen, muss man mit unterschiedlichen Seitenvorlagen arbeiten. Normalerweise heißt die Seitenvorlage "Standard". Man benutzt nun "Erste Seite" für die erste Seite, gefolgt von "Standard" für die folgenden. Weil die Fußzeile je Seitenvorlage einzeln ein-/ausgeschaltet wird, wird nur bei der Standard-Seite die Fußzeile eingeschaltet, in die der Feldbefehl für die Seitennummerierung eingefügt wird. Die erste Seite (mit Vorlage "Erste Seite") bleibt so ohne Nummerierung; OpenOffice.org beginnt die Folgeseiten dann mit Nummer 2. Seitenvorlagen kann aus dem Kontextmenü der Statusleiste (ganz unten, 2. Feld) auswählen.

Um die Seitennummerierung auf der 2. Seite (z.B. nach einem Deckblatt ohne Nummerierung) mit "1" starten zu lassen, benutzt man nicht (!) die Möglichkeit einer Korrektur des Feldbefehls, weil diese nicht bei Inhaltsverzeichnissen usw. berücksichtigt wird und zu einer fehlenden Anzeige auf den letzten Seiten führen kann. Stattdessen fügt man mit Einfügen->Manueller Umbruch einen manuellen Seitenumbruch ein (Achtung, Strg+Enter ist hierfür nicht geeignet). Als Vorlage wählt man die Seitenvorlage der Folgeseite: Hat man für die erste Seite "Erste Seite" benutzt, würde man ab der 2. Seite "Standard" benutzen (man kann aber auch dieselbe Seitenvorlage wie die bisher verwendete auswählen). Jetzt kann man die Option "Seitennummer ändern" aktivieren und hier einen beliebigen Wert für die Folgeseite einstellen. Dieses Verfahren klappt auch genauso an beliebigen anderen Stellen im Dokument (z.B. wenn die letzten 10 Seiten keine Nummerierung haben sollen).

Ausführlich ist dies unter http://www.ooowiki.de/SeitenNummerierung beschrieben.

Seitenvorlagen[Bearbeiten]

Mit F11 oder Format->Formatvorlagen das Fenster Formatvorlagen öffnen und mit einem Klick auf das entsprechende Icon den Bereich »Seitenvorlagen« aufrufen. Man sollte für den WikiReader eine Vorlage für die erste Seite haben, mehr und gleichmäßiger Rand, keine Seitenzahl.

Außerdem braucht man noch Vorlagen für die linke und rechte Seite. Größter Unterschied ist dabei der Seitenrand, den man innen (also bei der linken Seite rechts) größer machen sollte, damit man bei einem beidseitigen Druck nach dem Binden noch ein gutes Ergebnis hat. Ab einem halben Zentimeter Unterschied sollte es je nach Bindung reichen.

Seitenumbruch von erster Seite weg[Bearbeiten]

Nach der ersten Seite kann man über Einfügen->Manueller Umbruch eine Vorlage für die nächste Seite angeben. Es empfiehlt sich die rechte Seite anzugeben, wenn man den Druck plant.

Tabellen[Bearbeiten]

Bei Tabellen, die nicht die ganze Seite einnehmen, sollte man erst einen Rahmen (engl. Frame) erstellen und dort dann die Tabelle einfügen. Anders lässt sich die Tabelle nämlich nicht vernünftig platzieren.

Bilder[Bearbeiten]

Bilder sollte man in der großen Version runterladen (für den Ausdruck bräuchte man 300 dpi, Computerbildschirme haben nur 72 dpi) und lokal abspeichern. Beim copy'n'paste wird bei Bildern auch der Link auf die Beschreibungsseite mitkopiert, was sehr unpraktisch ist, weil in OOo der Weblink das Kontextmenü überlagert. Bilder also nach dem Kopieren rauslöschen und von der Festplatte einbinden.

Bilder sollten immer eine Beschriftung (über Kontextmenü) haben. Damit es mit der Nummerierung besser aussieht, empfiehlt es sich die Beschreibung im Eingabeforumlar mit " - " (leer strich leer) anzufangen.

Toolbars[Bearbeiten]

Was man in der Toolbar unbedingt braucht, ist die Funktion »Grafik einfügen« und »Indexmarkierung einfügen«.

Inhaltsverzeichnis[Bearbeiten]

Zweispaltig sollte man es auch bei DIN B5 noch schaffen. Bei DIN A5 wird es schon knapp daher könnte man da das Inhaltsverzeichnis in einen zweispaltigen »Bereich« (Frame) stecken und ein wenig Text in die zweite Spalte stellen.

Schneller kopieren / erstellen[Bearbeiten]

Ein paar Tipps wie man ein wenig schneller die Artikel nach OOo kopiert:

  • in MediaWiki die edit-section-links deaktivieren (Einstellungen)
  • Vor Bildern Stopp machen, die Überschriften sollte man noch mitnehmen
  • Bilder nicht per copy'n'paste einfügen sondern manuell

Offenen Fragen[Bearbeiten]

Hier dürft ihr eure Fragen stellen.

1. Meine Frage bezieht sich auf das copy and paste der Bilder. Ich habe alle Bilder in meiner Arbeit über den langen Weg verknüpft (Einfügen-->Grafik-->Aus datei). Mein Dokument enthält ca. 18 Bilder. Ich habe extra mit openoffice geschrieben, weil Word immer Probleme bei so viele Bilder macht. Wenn ich jetzt mein Dokument öffne, steht in den Rahmen der Bilder nur noch "Lesefehler" obwohl das Verzeichnis in dem die Bilder liegen noch vorhanden ist und alle Bilder ladbar sind. Wenn mir jemand einen Tipp geben könnte wäre ich echt dankbar. Gruß Andre

Schau mal nach, ob die Verknüpfungen bei dir relativ oder absolut angelegt sind. Hadhuey

2. Wie kann ich ein Inhaltsverzeichnis erstellen? Links sollten die Titel stehen und rechts die zugehörigen Seitenzahlen, was durch eine Linie von Punkten verbunden werden soll (etwa so: "1. Einleitung..................................Seite 2") Gruß Philip

Über Einfügen/Verzeichnisse/Verzeichnisse...; dann kommt ein Dialog, wo du das Aussehen beeinflussen kannst (Name des Verzeichnisses usw.) und z.B. bis zu welcher Ebene die Überschriften in das Verzeichnis aufgenommen werden sollen. (Kann man aber alles später durch Kontextmenü noch ändern.) --Christoph 22:13, 23. Nov 2005 (CET)

3. Wie kann ich ein Abbildungs- oder Tabellenverzeichnis erstellen, das über Hyperlinks verfügt, um direkt zum Objekt zu springen? Gleichzeitig soll aber die Kapitelnummerierung des Inhaltsverzeichnisses erhalten bleiben.

Hyperlinks sind z.Zt. nur in Inhaltsverzeichnissen möglich. --PiLu 15:27, 15. Sep. 2008 (CEST)

4. Wie kann man die Bilder kleiner machen, d.h in ihrer KB Größe, nicht in höhe und breite. Ich binde nämlich Bilder ein, und scale sie danach auf etwa 50 % ihre ursprünglichen Größe, jedoch hebe ich bei openoffice noch keine Möglichkeit gefunden, diese sozusagen auf die notwendige KB Größe zu komprimieren, wie bei Word, und lande so bei Dokumenten mit über 20 MB.

5. Wie kann ich bei OO Cal, einen Querstrich in einer Zelle machen, wo ich über und unter dem Strich was schreiben kann?

6. Ich möchte Bilder in OOCalc einfügen mit einer standardisierten Größe, z. B. 13 x 18 im Quer- bzw. 18 x 13 im Hochformat. Kann ich das irgendwo voreinstellen, dass ich nicht jedes Bild immer neu in der Größe definieren muss? Bei der Bildauswahl ist immer die Listenansicht voreingestellt - gibt es die Möglichkeit die Miniaturansicht voreinzustellen, dass ich das nicht auch bei jedem Bild erneut ändern muss? Gruß + danke Steffen

7. Bilder werden, wenn ich über das Menü <Einfügen->Bild->Aus Datei> gehe, standardmäßig immer als "verankert am Absatz" eingefügt. Gibt es eine Möglichkeit, diese Voreinstellung zu ändern und zum Beispiel Bilder immer als "Als Zeichen verankert" einzufügen?

8. Ich habe ein Inhaltsverzeichnis erstellt und möchte, dass es nicht nur die Seitenzahl, auf der der jeweilige Abschniss beginnt, sonder auch bis zu welcher Seite er geht, anzeigt. Also etwa: Überschrift 1..............................Seite 1 - 5 Wie geht das?

Bei den Einträgen in allen automatisch generierten Verzeichnissen bist du in der Auswahl auf das beschränkt, was auf dem Register Einträge unter "Struktur" steht; bei Inhaltsverzeichnissen stehen also nur "Kapitelnummer", "Eintragstext" (=Kapitelname), Tabulator (gefüllt/nicht gefüllt), Seitennummer, Hyperlink (Anfang/Ende) zur Verfügung. Davon abgesehen gibt es in OOo z.Zt. keine automatische Möglichkeit dafür, auf die Seitennummer einer ganz bestimmten Seite zu verweisen (ausgenommen über einen Querverweis auf einen Feldbefehl Seitennummer auf dieser Seite). --PiLu 15:27, 15. Sep. 2008 (CEST)

9. Wie kann ich per Macro Weblinks deaktivieren? Ich habe noch keine Möglichkeit gefunden. Jedoch kann man alle Links im OO-Dokument entfernen, indem man den Textabschnitt markiert und ihn per Linksklick-Kontext-Menü auf Standard (nicht zu verwechseln mit der Standard-Formatvorlage) setzt. Dabei gehen jedoch auch fette und kursive Formatierungen verloren. Hadhuey 11:02, 5. Apr 2005 (CEST)

Über Extras/Autokorrektur kannst du die automatische Erkennung von URLs ausschalten. Ist es das, was du gemeint hast? --Christoph 22:09, 23. Nov 2005 (CET)
Es besteht z.Zt. nur die Möglichkeit über Format->Standardformatierung einen Hyperlink zu entfernen, über den Hyperlink-Dialog (Einfügen->Hyperlink) ist dies z.Zt. nicht möglich (Issue 7311). Ob über Makros ein besserer Zugriff möglich ist, müsstest du bitte in einem geeigneteren Forum fragen. --PiLu 15:34, 15. Sep. 2008 (CEST)

10. Betrifft Inhaltsverzeichnis: Wie mache ich es, dass bei Eintragungen mit Zeilenumbruch (infolge zu langer Ueberschriften) es so aussieht (und zwar auch noch unmittelbar nach automatischer Verzeichnis-Aktualisierung!)?


2.3.9 Die Kapitelueberschrift ist
      zu lang
2.3.10 Diese Kapitelueberschrift
       ist auch zu lang

Oder meinetwegen auch so:

2.3.9  Die Kapitelueberschrift ist
       zu lang
2.3.10 Diese Kapitelueberschrift
       ist auch zu lang

--91.61.225.68 19:08, 27. Sep. 2008 (CEST)

Den einzelnen Einträgen im Inhaltsverzeichnis sind je nach Ebene per Default die Absatzvorlagen "Inhaltsverzeichnis 1", "Inhaltsverzeichnis 2" usw. zugewiesen. Definiere im Fenster Formatvorlagen (F11) diese Absätze als "Hängende Absätze", indem du auf dem Register "Einzüge und Abstände" einen positiven Einzug "vor Text" (z.B. 2 cm) und bei "erste Zeile" den betragsmäßig selben, aber negativen Einzug (z.B. -2 cm) einstellst. Auf dem Register "Tabulatoren" setzt du außerem noch einen linksbündigen Tabulator ohne Füllzeichen bei dieser Position (in diesem Beispiel bei 2 cm). Jetzt musst du nur noch bei der Erstellung des Inhaltsverzeichnisses bzw. indem du es bearbeitest (rechte Maustaste) auf dem Register "Einträge" in der Struktur einen Tabulator zwischen Kapitelnr. (E#) und Eintragstext (E) einfügen. Dies ergibt genau das von dir im zweiten Beispiel skizzierte Bild (für die anderen Überschriftenebenen entsprechend einstellen).
Das Thema automatische Verzeichnisse und ihre Gestaltung sprengt jedoch leicht den Rahmen dieser Sammlung von Tipps für das Erstellen eines Wikipedia-Readers, bitte lies deshalb erst einmal im OpenOffice.org-Wiki zu diesem Thema weiter. --PiLu 20:14, 27. Sep. 2008 (CEST)
Danke. Ich probierte es zunaechst fuer die Absatzvorlage "Inhaltsverzeichnis 3" aus: Es funktioniert leider nur bis zur naechsten Aktualisierung. Dann ist zwar die Absatzvorlage "Inhaltsverzeichnis 3" noch wie gewollt eingestellt, aber die betroffenen Zeilen im Inhaltsverzeichnis sind nicht dementsprechend (sie sind es erst wieder nach Anwenden der "Giesskanne").--91.61.242.226 23:37, 27. Sep. 2008 (CEST)
Deine Frage sprengt leider den Rahmen dieser Tippsammlung. Trotzdem noch ein paar Anmerkungen: Stelle sicher, dass du die jüngste Version von OOo, heruntergeladen von de.openoffice.org (also nicht von Novell oder Debian oder so), verwendest und nur im ODT-Format speicherst. Dann hat die Gießkanne in einem automatisch generierten Verzeichnis gar nichts zu suchen, weil dieses normalerweise schreibgeschützt ist (und sinnvollerweise auch sein sollte). Bearbeite dein Inhaltsverzeichnis (oder erstelle es am besten neu) und überprüfe, ob auf dem Register der "Ebene 1" die Absatzvorlage "Inhaltsverzeichnis 1" usw. zugeordnet ist. Die "Struktur" musst du für jede Ebene einzeln einstellen. Die Eigenschaften der Absatzvorlagen "Inhaltsverzeichnis 1" usw. bearbeitest du nur im Fenster Formatvorlagen (F11), nicht über Format -> Absatz. Die Kapitelnummerierung darfst du nur über Extras -> Kapitelnummerierung, nicht über nummerierte Listen vornehmen. Sollte dein Problem auch nach befolgen dieser Tipps immer noch bestehen, dann wende dich mit deinem Anliegen bitte an die Anwender-Mailingliste von OOo (Link ganz oben auf dieser Seite). --PiLu 00:30, 29. Sep. 2008 (CEST)

11. Wie verhindere ich, dass Fussnoten und das letzte Wort, auf das sich die Fussnote bezieht, durch einen Zeilensprung getrennt werden? Besten Dank.

12. 30.12.12 Beim Einfügen von Seitenzahlen sehr ich nicht die Seitennummer, wie man bei WYSIWYG erwarten dürfte, sondern nur das Wort "Seitennummer".

Schalte Ansicht -> Feldnamen wieder aus. Außerdem sei so gut und lies die ersten Zeilen auf dieser Seite noch einmal genau durch. --PiLu 01:30, 31. Dez. 2011 (CET)

13.Wieso Bleibt OOo immer stecken wenn ich was eingebe und auf enter drücke?

14. Wenn ich die erste Seite verändere, weil ich dort keine Fusszeile haben möchte (Deckblatt) wie kann ich dann 1. verhindern, dass die Seite doch mitgezählt wird in den Fusszeilen und 2. es hinbekommen, dass die zweite Seite (Inhaltsverzeichnis) genauso übernommen wird, ohne Fusszeile und ohne mitgezählt zu werden??

Bitte konsultiere das OOoWiki zum Thema Seitennummerierung, Seitenvorlagen und Seitenumbruch. Außerdem sei bitte so gut und lese dir die ersten Zeilen auf dieser Seite noch einmal genau durch. -- PiLu (Diskussion) 18:01, 6. Jun. 2012 (CEST)

Wie bekommt man alles was Text ist aus einem Open Office Text Dokument damit auf diesem nutr noch die Bilder sind ? Es hanelt sich um ein Dokument auf dessen sicherlich ca 1000 Bilder sind und dazwischen Texte, Tabellen usw.