Robot Karol

aus Wikipedia, der freien Enzyklopädie
Wechseln zu: Navigation, Suche

Robot Karol ist eine Programmierumgebung für eine gleichnamige in einfachem Deutsch gehaltene Programmiersprache. Sie wurde entwickelt, um Schüler, mit Hilfe der Programmierung von einfachen virtuellen Robotern, an die Algorithmik heranzuführen. Die Grundidee entstammt dem Buch Karel the Robot: A Gentle Introduction to The Art of Programming.

Geschichte[Bearbeiten | Quelltext bearbeiten]

Bei Robot Karol handelt es sich um eine, ab dem Jahr 2001 von Ulli Freiberger ins Deutsche übersetzte und deutlich erweiterte Variante der slowakischen Originalversion „Robot Karol++“.[1] Damit ist Robot Karol ein direkter und moderner Abkömmling von „Karel, the Robot“[2][3] sowie eine Alternative zur Turtle-Grafik und zu Niki – der Roboter. Die aktuelle Version ist 2.3 vom 12. April 2013.

Zweck[Bearbeiten | Quelltext bearbeiten]

Robot Karol wird als sogenannte „Mini-Language“ bezeichnet, also eine Sprache, die vor allem dazu dienen soll, Schülern einen ersten Einblick in die Programmierung und Algorithmik zu gewähren. Dabei ist es für Anfänger besonders nützlich, dass Robot Karol Programmiersprache und Programmierumgebung zugleich ist, was weitere Installationen, zum Beispiel die eines Editors oder eines Compilers zur Übersetzung des Quelltextes in Maschinencode, unnötig macht. Des Weiteren können die geschriebenen Programme für den virtuellen Roboter direkt, mit einem integrierten Interpreter, ausgeführt werden, wodurch die Erkennung von Fehlern zur Laufzeit in der grafischen Oberfläche von Karols Welt erleichtert werden.

Die hier gelernten Methoden können auch leicht auf „Java Karol“ übertragen werden. Hierbei handelt es sich um eine Java-Bibliothek, die ebenfalls von Ulli Freiberger 2008 entwickelt wurde und aktuell in der Version 1.1 vorliegt. Mit ihr ist es möglich, an Robot Karol angelehnte Methoden innerhalb eines Java-Quelltextes zu verwenden, um in die objektorientierte Programmierung eingeführt zu werden.[4] Damit bietet das Karol-Universum eine Schnittstelle zu einer der sogenannten Höheren Programmiersprachen.

Die Sprache[Bearbeiten | Quelltext bearbeiten]

Die Sprache setzt sich aus vordefinierten Anweisungen (zum Beispiel Schritt oder LinksDrehen), vordefinierten Bedingungen (zum Beispiel IstWand oder NichtIstWand) und Kontrollstrukturen (zum Beispiel wiederhole) zusammen. Diese drei Elemente werden ausführlich im Handbuch dokumentiert (auf das von der Anwendung aus zugegriffen werden kann). Daneben ist es auch möglich, Anweisungen und Bedingungen innerhalb der Gegebenheiten der Sprache selbst zu definieren.

Beispielprogramm[Bearbeiten | Quelltext bearbeiten]

Ein simples Beispielprogramm, in dem Karol bis zur nächsten Wand läuft und dann einen Ton von sich gibt. Um den eventuellen, späteren Zugriff auf diese Aktion zu erleichtern, wird sie als Anweisung definiert.

 {Das hier ist ein Kommentar}

 Anweisung SucheWand
   Wiederhole solange NichtIstWand
       Schritt
   *wiederhole
   Ton
 *Anweisung

 Programm
     SucheWand
 *Programm

Literatur[Bearbeiten | Quelltext bearbeiten]

Weblinks[Bearbeiten | Quelltext bearbeiten]

 Wikibooks: Programmierung von Robot Karol – Lern- und Lehrmaterialien

Einzelnachweise[Bearbeiten | Quelltext bearbeiten]

  1. Historie mebis-Infoportal des Landesmedienzentrums Bayern. Abgerufen am 28. Juli 2017
  2. Übersicht über die Entwicklungen von Karel (PDF, ≈ 1,7 MB) mebis-Infoportal des Landesmedienzentrums Bayern. Abgerufen am 28. Juli 2017
  3. karel.sourceforge.net Karel The Robot – auf Sourceforge.net, abgerufen am 1. März 2014
  4. Java Karol mebis-Infoportal des Landesmedienzentrums Bayern. Abgerufen am 28. Juli 2017