OpenCart

aus Wikipedia, der freien Enzyklopädie
Wechseln zu: Navigation, Suche
OpenCart
Opencart.png
Entwickler Daniel Kerr
Aktuelle Version 2.0.3.1
(29. Mai 2015)
Betriebssystem plattformunabhängig
Programmier­sprache PHP
Kategorie Onlineshop
Lizenz GPL (Freie Software)
Deutschsprachig ja
www.opencart.com

OpenCart ist ein freies Onlineshop-System.

Entwicklung[Bearbeiten | Quelltext bearbeiten]

Die Entwicklung basiert auf einem MVC-Framework, welches aber ausschließlich für das Shopsystem entwickelt wird.

Eigenschaften[Bearbeiten | Quelltext bearbeiten]

Ein wichtiges Merkmal von OpenCart ist die weitgehend (durch Verwendung einer Template Engine) freie Gestaltungsmöglichkeit in Design und Funktionen und die Möglichkeit, eines oder mehrere von vielen Modulen (Zusatzprogrammen) in der Software zu implementieren. So lassen sich beispielsweise Zahlungsmodule von Drittanbietern wie etwa PayPal in den Transaktionsprozess einbinden, um Kunden Bargeldlosen Zahlungsverkehr anbieten zu können.

Das Shopsystem ist in der serverseitigen Open-Source-Skriptsprache PHP geschrieben, als Datenbanksystem wird MySQL eingesetzt.

Die Administration und Konfiguration erfolgt über einen Webbrowser.

Sprachen[Bearbeiten | Quelltext bearbeiten]

Im Installationspaket von OpenCart ist nur die Englische Sprache enthalten, es lassen sich aber sehr leicht weitere Sprachen nachinstallieren.

Zurzeit sind nachfolgende Sprachpakete verfügbar (Stand: März 2013):

  • Arabisch
  • Bulgarisch
  • Chinesisch
  • Deutsch
  • Dänisch
  • Englisch
  • Finnisch
  • Französisch
  • Georgisch
  • Griechisch
  • Indonesisch
  • Italienisch
  • Japanisch
  • Katalanisch
  • Kroatisch
  • Litauisch
  • Malaysisch
  • Niederländisch
  • Norwegisch
  • Persisch
  • Polnisch
  • Portugiesisch
  • Rumänisch
  • Russisch
  • Schwedisch
  • Slowakisch
  • Slowenisch
  • Spanisch
  • Thailändisch
  • Tschechisch
  • Türkisch
  • Ukrainisch
  • Ungarisch
  • Vietnamesisch

Mittlerweile existiert auch eine komplette deutsche Übersetzung des Onlineshop-Systems (inkl. Lizenz, Anleitung, Installation, Benutzer- und Administrationsbereich).

Weiterentwicklung[Bearbeiten | Quelltext bearbeiten]

Dank einer aktiven Community wird ständig an der Weiterentwicklung und Verbesserung des Systems gearbeitet. Neben der aktuellen Version, gibt es noch eine von den Usern verbesserte Vorversion 0.7.9.

Systemanforderungen[Bearbeiten | Quelltext bearbeiten]

Die aktuelle Versionsreihe 1.x erfordert je nach Menge der Artikel ausreichend Webspace, PHP ab Version 5.x.x und eine MySQL-Datenbank ab Version 4.x.x.

Weblinks[Bearbeiten | Quelltext bearbeiten]