mod ruby

aus Wikipedia, der freien Enzyklopädie
Wechseln zu: Navigation, Suche
mod_ruby
Aktuelle Version 1.3.0
(8. November 2008)
Betriebssystem POSIX (Linux, Unix, u.a.)
Kategorie Apache-Modul
modruby.net

mod_ruby ist ein eingebetteter Ruby-Interpreter für den Apache web server, der es erlaubt, Ruby-Code direkt innerhalb von Apache auszuführen, schneller als mit anderen CGI-Methoden. Der Nachteil ist, dass das Teilen von Klassen zwischen den Apache-Prozessen beim gleichzeitigen Betrieb von mehreren Applikationen nicht sicher ist[1], das heißt, dass mehrere Ruby-on-Rails-Applikationen gleichzeitig laufen.

Heute ist mod_ruby weitgehend durch Phusion Passenger verdrängt bzw. ersetzt worden.

Weblinks[Bearbeiten]

Referenzen[Bearbeiten]

  1. mod_ruby Wiki, explaining the security problem of mod_ruby.